Wednesday, August 19, 2015

How To Open Broadband Business Anywhere in Bangladesh

আসসালামুওালাইকুম, কেমন আছেন সবাই? আসা করি সকলেই ভালো আছেন। আমিও ভালো আছি এবং আপনাদের দোয়ায় আমার Networking Solution Service এর কাজ খুব ভালোই চলছে। আজ অনেক দিন পরে আবারো আপনাদের মাঝে একটি টিউন করার জন্য হাজির হলাম। এবার আসি কাজের কথায় আসি আমি সাধারনতো Broadband Business চালু করতে যে সকল Technical Support দরকার তা দিয়ে থাকি। তো বিষয়টা নিয়ে অনেকেই আমার সাথে আলোচনা করেছে আসা করি আমি তাদের সকলকেই  সঠিক তথ্য দিতে পেরেছি আর যদি না দিতে পারি তাহলে আমাকে ক্ষমা করবেন কারন আমি আপনাদের কোন উপকারে আসতে পারিনি। আজ তার পরেও আমি আবার বিষয়গুলো নিয়ে বিস্তারিত আলোচনা করছি।
এখন আমি আপনাদের সাথে Networking / Internet এর business আপনি আপনার এরিয়াতে কীভাবে করবেন তা নিয়ে বিস্তারিত আলচনা করবো। আপনি যদি আপনার এরিয়াতে Networking / Internet এর business করতে চান তাহলে আপনাকে প্রথমেই যা করতে হবে তা নিচে ধাপে ধাপে আমি বর্ণনা করছি।
১। প্রথমেই আপনাকে খবর নিতে হবে যে আপনার এরিয়াতে কোন ISP Company (Internet Service Providers Company) আছে কিনা। যদি থাকে, তাহলে আপনি তাদের সাথে যোগাযোগ করে আপনার এরিয়াতে Local Area Distributor হিসাবে তাদের থেকে আপনার Bandwidth নিতে হবে। এখন আপনাদের অনেকের মনেই প্রশ্নআসতে পারে যে, Bandwidth কি?
উত্তরঃ  ১. একটি নির্দিষ্ট ব্যান্ড এর মধ্যে ফ্রিকোয়েন্সি পরিসীমা, বিশেষ করে যেটা একটি সংকেত প্রেরণের জন্য ব্যবহৃত।
          ২. 'ব্যান্ডউইথ' একটি নির্দিষ্ট সময়ের মধ্যে ওয়েবসাইট বা ইন্টারনেট  তথ্য সেবা থেকে আপনার কম্পিউটার স্থানান্তরিত করা যেতে পারে এবং  যা এর হার বর্ণনা করে। যখন আপনি কোন ওয়েব পেজ খোলেন, ফাইল ডাউনলোড করেন, তখন ব্যান্ডউইথ আপনার ইন্টারনেট কার্যকলাপ দক্ষতা এবং গতি পরিমাণ  নির্ধারণ করে। সাধারণত ব্যান্ডউইথ কখনও কখনও 'প্রতি সেকেন্ডে বিট' বা 'প্রতি সেকেন্ডে বাইট' হিসাবে পরিমাপ করা হয়।
          ৩. সহজ কথায় বলতে গেলে আমাদের ভাত খাবার জন্য যেমন চাউল এর প্রয়োজন তেমনি ইন্টারনেট, ব্রাউজিং, ডাউনলোড করার জন্য ব্যান্ডউইথ প্রয়োজন।

তো আপনারা ব্যান্ডউইথ এর জন্য Bangladesh ISP Company List. এই লিংক এ গেলে বিভিন্ন ISP Company (Internet Service Providers Company) এর Address & Contact number পাবেন সেখান থেকে আপনারা আপনাদের এরিয়া অনুযায়ী ISP Company (Internet Service Providers Company) এর সাথে Contact  করে আপনার এরিয়াতে যে ISP Company টা আছে তাদের থেকে Bandwidth Connection নিয়ে নিতে পারেন।

অথবা, আপনারা যদি মনে করে থাকেন যে, এই ব্যান্ডউইথ আপনারা ISP Company (Internet Service Providers Company) এর সাথে Contact  করে manage করতে পারছেন না তাহলে আপনারা এই ব্যাপারে সাহায্যের জন্য আমাদের সাথে যোগাযোগ করতে পারেন, আমরা বাংলাদেশের মধ্যে যে কোন জায়গাতেই আপনাদের Bandwidth Manage করে দিতে পারবো। Bandwidth Manage এর জন্য আমাদের কাছ থেকে সাহায্যের পেতে আপনাদের যা করতে হবে তা হলো আমাদের Application Form এ Apply  করতে হবে অথবা, আপনার নাম মোবাইল নাম্বার সহ আপনি কত MB Bandwidth নিতে চান তা উল্লেখ করে আপনার সম্পূর্ণ ঠিকানা (রোড নং, গ্রাম, ডাক ঘর টিউন কোড, থানা, জেলা) সহ আমাদের ইমেইল করুন trstnetwork@gmail.com অথবা আমাদের ফেসবুক ফেন পেজে টেক্সট করে পাঠান TRST Network
২। ISP Company এর সাথে যোগাযোগ করে Bandwidth Connection তো নিয়ে এলেন এখন কি করবেন? এখন আপনাকে যা করতে হবে তা হোল Networking অথবা আপনার ইউজারদের মধ্যে Bandwidth Distribute করার জন্য  আপনার কিছু Device কিনতে হবে।আমি  Device গুলোর নাম এবং কিছু সংক্ষিপ্ত বর্ণনা সহ নিচে ধাপে ধাপে উল্লেখ করছি আপনাদের সুবিধার জন্য।

MikroTik
১. MikroTik Router Board:  MikriTik টা সাধারনত আপনার Bandwidth Manage এবং ইউজারদের Bandwidth Distribute করার জন্য ব্যবহার হয়। আপনি কোন ইউজার কে কত MB Bandwidth দিবেন, কত MB Speed Limit দিবেন, কত MB Data Limit দিবেন তার সব কিছুই আপনারা এই MikriTik এর মাধ্যমে Manage করতে পারবেন। সম্পূর্ণ আপনার User Management বলতে যা কিছু বোঝায় তার সবকিছুই আপনি MikriTik দিয়ে করতে পারবেন। বাজারে আপনারা বিভিন্ন দামের এবং মডেলের MikriTik পাবেন। MikriTik এর বাজার মূল্য ৫০০০ টাকা থেকে শুরু করে ১৫০০০০ টাকা পর্যন্ত এবং এর চাইতেও বেশি দামের MikriTik আপনারা বাজারে পাবেন।

Fiber Optic Cable
২. Fiber Optic Cable: এই Cable ব্যবহার হয় সাধারনত মেইন লাইন টানার জন্য। ISP Company থেকে মেইন লাইন টানার জন্য এবং আপনাদের MikroTik এর LAN port থেকে Local Area Networking এর জন্য এই Cable ব্যবহার হয়। এই Cable এর এক একটা core দিয়ে এক একটা নেটওয়ার্ক বিন্যাস করা যায়। এই ক্যাবলে তামার তারের চেয়ে কাচকে মিডিয়া হিসেবে ব্যবহার করা হয়েছে। ফলে ইলেকট্রো ম্যাগনেটিক ইন্টারফের‌্যান্স নেই। এই ক্যাবলের ডাটা ট্রান্সমিসন স্পীড অনেক বেশী। ফাইবার অপটিক ক্যাবল দুই ধরনের হয়ে থাকে। সিঙ্গল মোড ফাইবার এন্ড মাল্টিমোড ফাইবার। বর্তমানে বাজারে 4 core এর Fiber Optic Cable এর মূল্য প্রতি মিটার ১৪ টাকা। এছাড়াও আপনারা বাজারে আরও অনেক বেশি core এর Fiber Optic Cable পাবেন...।।

Twisted Pair Cable/ UTP Cable
৩.Twisted Pair Cable/ UTP Cable: এই Cable সাধারনত সুইজ থেকে ইউজারদের কম্পিউটার পর্যন্ত ইন্টারনেট কানেকশন দেওয়ার জন্য ব্যবহার হয়। ট্যুইস্টেড পেয়ার ক্যাবল দুই দরনের হয়ে থাকে। ১. শিল্ডেড ট্যুইস্টেড পেয়ার ক্যাবল, ২.আনশিল্ডেড ট্যুইস্টেড পেয়ার ক্যাবল।

·         শিল্ডেড ট্যুইস্টেড পেয়ার ক্যাবল
শিল্ডেড ট্যুইস্টেড পেয়ার ক্যাবলে প্রতিটি ট্যুইস্ট জোড়া থাকে একটি করে শক্ত আচ্ছাদনের ভেতর। ফলে ইলেকট্রিক ইন্টারফের‌্যান্স অনেক কম থাকে। এই ক্যাবলের ডাটা ট্রান্সফার স্পীড ৫০০ এমবিপিএস হয়ে থাকে।
·         আনশিল্ডেড ট্যুইস্টেড পেয়ার ক্যাবল
আনশিল্ডেড ট্যুইস্টেড পেয়ার ক্যাবলে পেয়ারের বাইরে অতিরিক্ত কোন শিল্ডিং থাকে না কেবল বাহিরে একটি প্লাষ্টিকের জেকেট থাকে। এই ক্যাবলের ডাটা ট্রান্সফার রেট ১৬ এমবিপিএস।


Switch
৪. Switch: Switch ব্যবহার করা হয় Local Area Network এর মধ্যে ছোট ছোট পপ করার জন্নে। Twisted Pair Cable/ UTP Cable বা Fiber Optic Cable বেশ কিছুদুর টানার পরে একটা নির্দিষ্ট এরিয়াতে বেশ কিছু ইউজার কে একটা UTP Cable অথবা Fiber Optic Cable এর একটা চরে থেকে কানেকশন দিতে এই Device ব্যবহার করা হয়। সুইজ হলো একাধিক পোর্ট বিশিষ্ট ব্রিজ।ইহা প্রতিটি নোডের ম্যাক এড্রেস এর তালিকা সংরক্ষন করে। ইহা ওএসআই মডেল এর ডাটালিংক লেয়ারে কাজ করে।

Media Converter
৫. Media Converter: Fiber Optic Cable এর একটি Core কে Splice Machine এর দ্বারা Patch Cord এর দ্বারা এই Device এর সাথে Connect করে Ethernet Port এ Convert করার জন্য Media Converter ব্যবহার করা হয়। এই Device use করলে Ethernet Speed বেড়ে যায়।

Patch Cord
৬. Patch Cord: Fiber Optic Cable এর একটি Core কে Splice Machine এর দ্বারা Patch Cord এর সাথে Joint দিয়ে ব্যবহার করা হয় Media Converter এর সাথে Connect করার জন্য।


৭. Splice Machine: Fiber Optic Cable এর Core Joint এর কাজে Splice Machine ব্যবহার হয়।

Router
৮. Router: Router use করা হয় Mobile Device গুলতে WiFi use করার জন্য। ইউজারা সাধারনত তাদের ঘরে Mobile, Laptop অথবা অন্য কোন WiFi Enable Device এ Internet use করার জন্য Router ব্যবহার করে থাকে।


Radio Device
৯. Radio Device: এই Device গুল ব্যবহার করা হয় Long Rang WiFi Zone করার জন্য। এই Device গুল দুই ধরনের হয় একটা 2.4GHZ এবং 5GHZ এর হয়ে থাকে। 2.4GHZ এর Device দিয়ে আমরা Long Rang WiFi Zone করতে পারি কারন আমাদের দেশের WiFi Enable Device গুল 2.4GHZ এর বেশি Support  করতে পারে না। আপনারা যারা Long Rang WiFi Zone করতে চান তারা এই Device এর মাধ্যমে Maximum 1KM এরিয়া WiFi Zone করতে পারবেন। এছাড়াও আপনারা এই Device গুলর মাধ্যমে 50+KM Distance এ Bandwidth Through করতে পারবেন। Long Distance এ Bandwidth Through/Received করার জন্য 5GHZ এর Device ব্যবহার করা সবচাইতে বেশি ভালো।

এখানে আপনারা যারা আপনাদের এরিয়াতে ব্রডব্যান্ড ব্যবসা Cable কানেকশন দিয়ে করতে চান তাহলে (Mikrotik Routerboard, Fiber Optic Cable, Twisted Pair Cable/ UTP Cable, Router, Switch, Computer) এই Device গুল ব্যবহার করবেন এবং আপনি যদি আপনার এরিয়াতে ব্রডব্যান্ড ব্যবসা WIFI Connection দিয়ে করতে চান তাহলে আপনার (Mikrotik Routerboard, Computer, Router, Radio Device m2) এই Device গুল ব্যবহার করবেন।

৩। Bandwidth Connection চলে আসলো Device কেনা হয়ে গেল এবং Device সম্পর্কে কিছু ধারনাও হয়ে গেল। এখন আপনি ব্যবসা করবেন কীভাবে বা আপনার এরিয়ার Clint দের Internet Connection কীভাবে দিবেন, কীভাবে তাদের ১টি নির্দিষ্ট Speed Limit দিবেন, কিভাবে MikroTik Configure করবেন? এটা নিয়ে আপনার চিন্তা করার কোন কারন নেই এজন্য আমরা আপনাকে সাহায্য করবো। আমরা আপনার Networking এর সব কিছু Setup করে আপনাকে শিখিয়ে দিবো যে কীভাবে আপনাকে Networking করতে হবে এবং কীভাবে আপনি আপনার Clint দের Service দিতে পারবেন।

এখন আপনাদের যদি আরও কিছু জানার থাকে তাহলে আমার সাথে ফোনে/ ফেসবুকে যোগাযোগ করুন।
Contact us:
Name- Tanvir Ahmed
Facebook Id- Tanvir Ahmed
Facebook Fan Page- TRST Network
Email-trstnetwork@gmail.com

Friday, June 5, 2015

Data Communication & Wireless Communication System

আজ আমি ডেটা কমিউনিকেশন & ওয়ারলেস্ কমিউনিকেশন সিস্টেম সম্পর্কে আলোচনা করবো।তো কথা না বাড়িয়ে মুল আলোচনায় যাই.....
ডেটা কমিউনিকেশন (Data Communication)
কম্পিউটার বা অন্য কোন যন্ত্রের মাধ্যমে ডেটাকে একস্থান হতে অন্য স্থানে বা এক ডিভাইস হতে অন্য ডিভাইসে স্থানান্তর প্রক্রিয়াই হচ্ছে ডেটা কমিউনিকেশন।
ডেটা ট্রান্সমিশন স্পীড (Data Transmission Speed)
এক স্থান হতে অন্য স্থানে কিংবা এক কম্পিউটার হতে অন্য কম্পিউটারে ডেটা স্থানান্তরের হারকে ডেটা ট্রান্সমিশন বলে স্পীড।এই ট্রান্সমিশন স্পীডকে অন্য সময় Bandwidth বলা হয়।এই ব্যান্ডউইথ ষাধারণত Bit Per Secound (bps) এ হিসাব করা হয়।একে Band Speed ও বলা হয়। এই ডেটা ট্রান্সফার গতির উপর ভিত্তি করে কমিউনিকেশন গতিকে তিন ভাগে ভাগ করা হয়-
(ক) ন্যারো ব্যান্ড ( Narrow Band)
এই ব্যান্ডের ডেটা সাধারণত ৪৫ থেকে ৩০০bps পর্যন্ত হয়ে থাকে। টেলিগ্রাফিতে সাধারণত এই ব্রান্ডকে ব্যবহার করা হয়।
(খ) ভয়েস ব্যান্ড (Voice Band)
ব্যান্ডের ডেটা সাধারণত ৯৬০০bps পর্যন্ত হয়ে থাকে।এটি সাধারণত টেলিফোনে ব্যাবহৃত হয়।
(গ) ব্রড ব্যান্ড (Broad Band)
ব্রড ব্যান্ড উচ্চগতি সম্পন্ন ডেটা স্থানান্তর ব্যান্ডউইথ যার গতি কমপক্ষে ১ মেগা বিট পার সেকেন্ড হতে অত্যন্ত উচ্চ গতি পর্যন্ত হতে পারে ।সাধারণত কো অ্যাক্সিয়াল ক্যাবল ও অপটিক্যাল ফাইবারে ডেটা স্থানান্তরে ব্রডব্যান্ড ডেটা ট্রান্সমিশন ব্যবহার করা হয়। এছাড়া স্যাটেলাইট কমিউনিকেশন এবং মাইক্রোওয়েভ কমিউনিকেশনেও এই ব্যান্ড ব্যবহৃত হয়।

ওয়ারলেস্ কমিউনিকেশন সিস্টেম:-
Wireless Communication System
কোন প্রকার তার ব্যবহার না করেই আদান-প্রদান তথা যোগযোগ করার পদ্ধতিকে ওয়ারলেস্ কমিউনিকেশন সিস্টেম বলে।এর সাহায্যে বিশ্বের যেকোন প্রান্তে অবস্থান করেই একে অন্যের সাথে বিভিন্ন প্রকার যোগাযোগ যেমন-কথা বলা,টেক্সট মেসেজিং,চ্যাটিং ইত্যাদি কাজ খুব সহজেই করতে পারে।
হটস্পট (Hotspot):-
হটস্পট হল এক ধরনের ওয়ারলেস নেটওয়ার্ক যা মোবাইল কম্পিউটার ও ডিভাইস যেমন; স্মার্ট ফোন,পিডিএ,ট্যাব,নেটবুক বা ল্যাপটপ ইত্যাদিতে ইন্টারনেট সংযোগ সরবরাহ করে।বর্তমানে জনপ্রিয় তিনটি হটস্পট প্রযুক্তি হলো-
১।ওয়াই-ম্যাক্স
২।ওয়াই-ফাই
৩।ব্লু-ট্রুথ
ওয়াই-ম্যাক্স (WiMAX)
ওয়াই-ম্যাক্স একটি উচ্চগতির ব্রটব্যান্ড যোগাযোগ প্রযুক্তি যা বিস্তৃত অঞ্চলে দ্রুতগতির তারবিহীন ইন্টারনেট সেবা প্রদান করে। WiMAX এর পূর্ণরুপ হলো Worldwide Interoperability For Microwave Access।এটি প্রযুক্তিগতভাবে  IEEE802.16নামে পরিচিত।

ওয়াই-ফাই(WI-Fi)
ওয়াই-ফাই যা ওয়্যারলেস ফেডালিটি(Wireless Fidelity) হচ্ছে এক ধরনের জনপ্রিয় তারবিহীন প্রযুক্তি যা রেডিও ওয়েভ ভ্যবহার করে কোন ইলেকট্রনিক ডিভাইসকে উচ্চহতিরইন্টারনেট সংযোগ কিংবা কম্পিউটার নেটওয়ার্কের মাধ্যমে ডেটা –আদান প্রদান করতে পারে।এর স্ট্যান্ডর্ড হলো IEEE 802.11 এটি WiMAX এর চেয়ে অপেক্ষাকৃত   ধীরতির।
ব্লু-ট্রুথ (Bluetooth)
ব্লু-ট্রুথ হলো তার বিহীন পার্সনাল এরিয়া নেটওয়ার্ক (PAN) যা স্বপ্ল দূরত্বে ডেটা আদান প্রদানে ব্যাবহৃত হয়। এর দূরত্ব সাধারণত ১০ থেকে ১০০ মিটার হয়ে থাকে।ব্লু-ট্রুথ প্রযুক্তিতে কম ক্ষমতাসম্পন্ন বেতার তরঙ্গ (Radio Wave) ব্যবহার করা হয়। এর স্ট্যান্ডার্ড হলো IEEE 802.15

Ping 2 Verify The Net Cnnectivity

বাংলাদেশের ইন্টারনেট ব্যবহারকারীর সংখ্যা হাতে গোনা ১২ থেকে ১৫ লক্ষ যা কিনা বাংলাদেশের মোট জনসংখ্যার ১% এর অনেক কম (প্রায় দশমিক নয় পার্সেন্ট)। এই আশা ব্যাঞ্জক ইউজার রা যারা আছেন তাদের অধিকাংশই মোবাইল এজ এর মাধ্যমে নেট ইউজ করেন। আর বাকীদের অনেকেই তারযুক্ত ব্রডব্যন্ড ব্যবহার করেন। আর ইদানিং যুক্ত হয়েছে ওয়াইম্যাক্স প্রযুক্তি।
তো এই নেট যখন আমরা আমাদের পিসিতে বা ল্যপটপে ব্যবহার করি মাঝে মাঝে নেট কানেকশানে সমস্যা হয়। অনেকেই বুঝতেও পারেন না সমস্যাটা কি তারে, নাকি তার পিসিতে, নাকি তার কানেকশানে। তাই আজকে আমরা খুব ছোট একটা রান কমান্ড দিয়ে জেনে নিবো সমস্যার মূল কোথায়।
নেট কানেকশান যাচাইকরনঃ

০১. উইন্ডোজের নেটওয়ার্ক প্রপার্টিজ থেকে আপনার নেটোয়ার্ক কানেকশানটি সক্রিয়/এনাবল করুন;
০২. আইপি সংক্রান্ত কোন কনফিগারেশান থাকলে তা কানেকশান প্রপার্টিজ থেকে ইন্টারনেট প্রটোকল(TCP/IP) তে ডাবল ক্লিক করুন
০৩. ঠিকমত আইপি, সাবনেট মাস্ক, ডিফল্ট গেট ওয়ে সহ ডিএনএস গুলো বসিয়ে ওকে করে অকে করুন।
০৪. আর অটোমেটিক আইপি হলেতো আর ঝামেলাই নেই; অবটেইন এন আইপি এড্রেস অটোমেটিকাল দিয়ে দিন
০৫. এবার আপনার টাস্কবারের ডানে আইকন আসবে।
০৬. এবার ষ্টার্ট মেনু থেকে রান চালু করে লিখুন
ping 8.8.4.4 -t
০৭. এই পিং এড্রেস দিয়ে ওকে করলে কয়েক রকম রেজাল্ট আসতে পারে, যেমন
ক. Reply From 8.8.4.4: bytes=XX time=XXXms TTL=XX
খ. Request timed out
গ. Destination Host Unreachable
ঘ. Hardware error
বর্তমান নেট কানেকশান এর অবস্থাঃ
উপরের পদ্ধতিতে পিং করে আপনি যা পাবেন নিচে তার সাথে মিলিয়ে নিন
ক = নেট কানেকশান ঠিক আছে
খ = পিং মিসিং/কনফিগারেশানে সমস্যা আছে
গ = আপনার নেটওয়ার্ক কানেকশান অচল/ডিজেবল অবস্থায় আছে
ঘ = আপনার লাইন/তার ডিস্কানেক্ট থাকলে
ভাল লেগে থাকলে আমাদের সাথে সবসময় থাকতে পারেন.

Find out the details of the code HTTP

ইন্টারনেটে ব্রাউজ করতে করতে আমরা বিভিন্ন সময়ই দেখি 404 Page not found বা 503 Service unavailable এরকম এরর। এছাড়াও আরো বিভিন্ন HTTP Success অথবা Error কোড চোখে পড়ে আমাদের। কিন্তু অনেকেই জানেনা বিভিন্ন নাম্বার সম্বলিত সেই কোডগুলো সম্বন্ধে তাই আজ আমার এই টিউনে আমি সেই কোডগুলো সম্বন্ধেই একটু ধারনা দিতে চেষ্টা করবো।
url-redirection

1xx Informational

১ দিয়ে শুরু হওয়া কোডগুলো বুঝায় যে অনুরোধ গৃহিত হয়েছে সার্ভারে, এবং অনুরোধটি প্রসেস করা হচ্ছে।
(শুধু স্টেটাস লাইন ও অপশনাল হেডারের মাধ্যমে এ ধরনের স্টেটাস কোড বিভিন্ন শর্তাধীনে রিস্পন্স করা নির্দেশ করে থাকে। যেহেতু HTTP/1.0 তে 1xx স্টেটাস কোড ব্যবহৃত হয় না, তাই পরীক্ষামূলক কোন পরিস্থিতি ছাড়া সার্ভারের অবশ্যই কোন HTTP/1.0 ক্লায়েন্টের কাছে 1xx রিস্পন্স পাঠানো উচিত হবে না।)

100 continue

এটা দ্বারা বুঝায় যে, সার্ভারে রিকোয়েস্টেড হেডারগুলো গৃহীত হয়েছে, এবং ক্লায়েন্ট রিকোয়েস্টেড বডি প্রেরণ করতে পারে। ভুল হেডারের কারনে সার্ভারে কোন রিকোয়েস্ট ব্যর্থ হলে বড় আকারের রিকোয়েস্টেড বডি সার্ভারে প্রেরন করা বৃথা। শুধু হেডারের উপর ভিত্তি করে রিকোয়েস্ট গৃহীত হবে কিনা তা জানার জন্য জন্য সার্ভার চেক করতে একজন ক্লায়েন্টকে অবশ্যই হেডারের প্রারম্ভিক রিকোয়েস্ট হিসেবে Expect: 100-continue কোড প্রেরন করতে হবে এবং কাজ শুরু চালানো শুরু আগে, অবশ্যই চেক করে নিতে হবে যে, 100-continue স্টেটাস কোড সার্ভার কতৃক গৃহীত হয়েছে। (যদি সার্ভার রিস্পন্স হিসেবে 417 Expectation Failed কোড সো করে কন্টিনিউ করা উচিত হবে না।)

101 Switching Protocols

এই কোড দ্বারা বুঝায় অনুরোধকারী সার্ভারকে প্রোটোকল সুইচ করতে অনুরোধ করছে এবং সার্ভারও তাতে সাড়া দিয়েছে।

102 Processing (WebDAV) (RFC 2518)

যেহতু একটি WebDAV রিকোয়েস্ট অনেক সাব-রিকোয়েস্ট ধারন করতে পারে তাই এ ধরনের রিকোয়েস্ট সম্পাদন করতে অনেক সময় লাগতে পারে। এ ধরনের কোড বুঝায় যে, সার্ভার কতৃক রিকোয়েস্ট গৃহীত হয়েছে এবং সার্ভার রিকোয়েস্ট প্রসেস করছে কিন্তু এখন পর্যন্ত কোন রিস্পন্স পাওয়া যাচ্ছে না। এর ফলে ক্লায়েন্ট বুঝতে পারে যে কাজ চলছে এবং তার রিকোয়েস্টটি হারিয়ে যায়নি।

2xx Success

এই শ্রেনীর স্টেটাস কোড বুঝায় যে, ক্লায়েন্টোর দ্বারা অনুরোধকৃত কাজটি গৃহীত হয়েছে, তা বোঝা গেছে, অনুমোদিত হয়েছে এবং সফলতার সাথে প্রসেস করা হয়েছে।
070720a0280

200 OK

এটি একটি সফল HTTP রিকোয়েস্টের আদর্শ রিস্পন্স। প্রকৃত রিস্পন্স সাধারণত রিকোয়েস্টের পদ্ধতির উপর নির্ভর করে। একটি GET রিকোয়েস্টের ক্ষেত্রে, রিস্পন্সের সাথে “অনুরোধকৃত রিসোর্সের সাথে রিকোয়েস্টের একটি এনটিটিও যুক্ত থাকে। POST রিকোয়েস্টের ক্ষেত্রে, রিস্পন্সের সাথে অনুরোধকৃত কাজের ব্যাখ্যা বা ফলাফল যুক্ত থাকে।

201 Created

এই কোডটি দ্বারা বুঝায় যে, অনুরোধটি গৃহীত হয়েছে যার ফলে একটি নতুন রিসোর্স তৈরি করা হচ্ছে।

202 Accepted

এ কোডটি দ্বারা বুঝায়, প্রসেসিংয়ের জন্য রিকোয়েস্টটি গৃহীত হয়েছে, কিন্তু প্রসেসিং সম্পাদিত হয়নি।

203 Non-Authoritative Information (since HTTP/1.1)

এ কোডের দ্বারা বুঝায় সার্ভার সফলতার সাথে রিকোয়েস্ট সম্পাদিত করেছে, কিন্তু এ থেকে যে তথ্য পাওয়া যাচ্ছে তা সম্ভবত অন্য কোন উৎস থেকে আসছে।

204 No Content

এ কোডের দ্বারা বুঝায় যে সার্ভার সফলতার সাথে অনুরোধ সম্পাদিত করেছে, কিন্তু কোন কন্টেন্টই নাই।

205 Reset Content

এ কোড দ্বারা বুঝায় সার্ভার সফলতার সাথে অনুরোধ সম্পাদিত করেছে কিন্তু কোন কন্টেন্টই আসছে না। 204 কোডের চেয়ে কিছুটা ভিন্ন এ কোডের ক্ষেত্রে রিস্পন্সটি অনুরোধকারীকে তার ডকুমেন্ট ভিউকে রিসেট করতে বলে।

206 Partial Content

এ কোডটি বুঝায় ক্লায়েন্টের পাঠানো রেঞ্জ হেডারের কারনে সার্ভার রিসোর্সের মাত্র একটি অংশ প্রেরন করছে। রিজিউম, বাধাগ্রস্থ ডাউনলোড এবং একটি ডাউনলোডকে একইসাথে বহুমুখি স্ট্রীমের মাধ্যমে ভাগ করে ডাউনলোডের ক্ষেত্রে এ কোডটি wget টুলস কর্তৃক ব্যবহৃত হয়ে থাকে।

207 Multi-Status (WebDAV) (RFC 2518)

এ কোড বুঝায় যে ম্যাসেজের বডিটি একটি XML ম্যাসেজ, যা ভিন্ন ভিন্ন সাব-রিকোয়েস্টের জন্য ভিন্ন ভিন্ন রিস্পন্স কোড ধারন করে থাকে।

3xx Redirection

এই শ্রেনীর কোডের ক্ষেত্রে এটা বুঝায় যে রিকোয়েস্ট সম্পাদিত করতে ক্লায়েন্টকে অবশ্যই রিডিরেক্ট হবে।
redirection
যদি এবং কেবল যদি দ্বিতীয় রিকোয়েস্টের ক্ষেত্রে GET অথবা HEAD পদ্ধতি ব্যবহার করা হয় তাহলে হয়তোবা ঐ অ্যাকশন ব্যাবহারকারীর সাথে কোন ক্রিয়া-প্রতিক্রিয়া ছাড়াই ব্যবহারকারীর এজেন্টের মাধ্যমে সম্পাদিত হবে। ব্যবহারকারীর এজেন্ট কখনোই কোন রিকোয়েস্টকে পাঁচ মিনিটের বেশি রিডিরেক্ট করতে পারবে না, কারন তখন বুঝা যায় যে হয়তো এ ধরনের রিডিরেকশন একটি অনির্দিষ্ট লুপ বা চক্রের সৃষ্টি করছে।

301 Moved Permanently

এ কোড দ্বারা বুঝায় এটি এবং ভবিষ্যতের সকল রিকোয়েস্ট প্রদত্ত্ব URL এ ডিরেক্ট করে দেয়া হবে।
_B296487

302 Found

এটি সবচেয়ে জনপ্রিয় রিডিরেক্ট কোড কিন্তু এটি একটি ইন্ডাস্ট্রিয়াল প্রেকটিস যা স্টেন্ডার্ড নীতির বিরোধী। HTTP/1.0 মতে একজন ক্লায়েন্ট শুধু অস্থায়ী রিডিরেক্ট করতে পারবেন, কিন্তু জনপ্রিয় ব্রাউজার 302 কোড কে 303 see other কোডের মত বাস্তবায়িত করেছে। সেই জন্যেই HTTP/1.1 এ স্টেটাস কোড 303 এবং 307 কে যুক্ত করেছে, যাতে ঐ ভিন্ন দুটি আচরনকে স্বাতন্ত্র্য করা যায়। যাইহোক, এখনো বেশির ভাগ ওয়েব অ্যাপ্লিকেশন এবং ফ্রেমওয়ার্কই 302 স্টেটাস কোডকে এমন ভাবে ব্যবহার করে যেন এটি 303।

303 See Other (since HTTP/1.1)

এ কোডটি দ্বারা বুঝায় যে অনুরোধের রিস্পন্সটি GET পদ্ধতির সাহায্যে আরেকটি URL থেকে পাওয়া যাবে। যখন PUT এর রিস্পন্স হিসেবে এ ধরনের কোড পাওয়া যাবে, তখন বুঝতে হবে যে, সার্ভার ডাটা রিসিভ করেছে এবং রি-ডিরেক্ট আরেকটি GET ম্যাসেজের মাধ্যমে ইস্যু করতে হবে।

304 Not Modified

এ কোডের মাধ্যমে বুঝায় যে সর্বশেষ রিকোয়েস্টের পর রিসোর্সটিকে আর মডিফাই করা হয়নি।

305 Use Proxy (since HTTP/1.1)

প্রাথমিক নিরাপত্তার কারনে মজিলা এবং ইন্টারনেট এক্সপ্লোরারের মত অনেক HTTP ক্লায়েন্ট এ স্টেটাস কোডের সাহায্যে সঠিকভাবে রিস্পন্স করে না।

306 Switch Proxy

আর ব্যবহার করা হয় না।

307 Temporary Redirect (since HTTP/1.1)

এ কোডের ক্ষেত্রে অন্যকোন URI এর মাধ্যমে পুনরায় রিকোয়েস্ট করতে হবে। কিন্তু ভবিষ্যতের রিকোয়েস্টগুলো ক্ষেত্রে তারপরেও অরিজিনাল URI ব্যবহার করা যেতে পারে। 303 এর সাথে তুলনা করতে গেলে, এ ক্ষেত্রে রিকোয়েস্ট রি-ইস্যু করার সময় রিকোয়েস্টের পদ্ধতি পরিবর্তন করা যাবে না। উদাহরণস্বরূপ: একটি POST রিকোয়েস্ট অবশ্যই পুনরায় ইস্যু করার সময় আরেকটি POST রিকোয়েস্ট ব্যবহার করতে হবে।

4xx Client Error

ক্লায়েন্ট কোন ভুল করলে এ শ্রেনীর স্টেটাস কোড ব্যবহৃত হয়। শুধু HEAD রিকোয়েস্ট ছাড়া বাকি সবগুলো রিস্পন্সের সাথেই সার্ভার ভুলের ব্যখ্যা সহ একটা এনটিটি যুক্ত করে দেয় এবং আরো জানিয়ে দেয় এ পরিস্থিতি কি স্থায়ী না অস্থায়ী। যেকোন রিকোয়েস্ট পদ্ধতির ক্ষেত্রেই এ স্টেটাস কোডগুলো প্রযোজ্য। এক্ষেত্রে ব্যবহার কারীর এজেন্ট সকল যুক্ত এনটিটিগুলোকে প্রদর্শিত করে। নিচে সাধারনতো সবচেয়ে বেশি ব্যবহৃত Error কোডগুলো দেয়া হল:
404-error

400 Bad Request

এ কোড বুঝায় যে রিকোয়েস্টে পদবিন্যাসে ভুল রয়েছে।

401 Unauthorized

এটি 403 Forbidden কোডের অনুরূপ কিন্তু শুধুমাত্র authentication সম্ভব হয়।

402 Payment Required

এ কোডটি বুঝায় ভবিষ্যতে ব্যবহারের জন্য সংরক্ষন করা হল। আসলে প্রকৃত উদ্দেশ্যটি হল, এ কোড সাধারণত কোন ডিজিটাল ক্যাস বা মাইক্রোপেইমেন্টোর পরিকল্পনার একটি অংশ হিসেবে ব্যবহৃত হওয়ার কথা, যেহেতু তা হয়নি তাই এই কোডও কখনো ব্যবহৃত হয়নি।
jamalgota_1221321151_1-3

403 Forbidden

এ কোড দ্বারা বুঝায় রিকোয়েস্টটি একটি লিগাল রিকোয়েস্ট ছিল, কিন্তু সার্ভার এ রিকোয়েস্টের জন্য রিস্পন্স করতে অসম্মতি জানাচ্ছে।
error403

404 Not Found

এ কোডের দ্বারা বুঝায় অনুরোধকৃত রিসোর্চ বর্তমানে পাওয়া সম্ভব নয়, তবে ভবিষ্যতে পাওয়া যেতে পারে। এর পরবর্তিতে ক্লায়েন্টোর আরো রিকোয়েস্ট করা অনুমোদিত।
normal_Funny_Error_404

405 Method Not Allowed

এ কোড দ্বারা বুঝায় এমন একটি পদ্ধতির সাহায্যে রিসোর্স রিকোয়েস্ট করা হয়েছে যা ঐ রিসোর্স সাপোর্ট করে না। উদাহরনস্বরূপ: যেখানে POST প্রয়োজন সেখানে GET পদ্ধতি ব্যবহার করলে এ স্টেটাস কোডটি প্রদর্শিত করবে।
158550668_7db98488d6

406 Not Acceptable

এ কোড দ্বারা বুঝায় রিকোয়েস্টেড রিসোর্স শুধু সেই কন্টেন্ট তৈরী করতে সক্ষম যা রিকোয়েস্টের সাথে প্রেরীত Accept headers অনুসারে গ্রহণযোগ্য নয়।

408 Request Timeout

এ কোড দ্বারা বুঝায় রিকোয়েস্টের জন্য অপেক্ষার করতে করতে সার্ভারের টাইম আউট হয়ে গেছে।

409 Conflict

এ কোড বুঝায় যে রিকোয়েস্ট সম্পাদিত করা যাচ্ছে না কারন রিকোয়েস্টের মধ্যে Conflict রয়েছে। যেমন: Edit-conflict.

410 Gone

এ কোড দ্বারা বুঝায় যে অনুরোধকৃত রিসোর্চ এখন আর পাওয়া সম্ভব নয় এবং ভবিষ্যতেও পাওয়ার সম্ভাবন নেই।
05_23_1---Graveyard_web

411 Length Required

এ কোড বুঝায় যে রিকোয়েস্টের সাথে কন্টেন্টের লেন্থ দিয়ে দেয়া হয়নি, যা অনুরোধকৃত রিসোর্চ ব্যবহারের ক্ষেত্রে প্রযোজ্য।

412 Precondition Failed

এ কোডটি বুঝায় আনুরোধকারীর রিকোয়েস্টে একটি পূর্বশর্ত মেনে চলা হয়নি।

413 Request Entity Too Large

এ কোডটি বুঝায় যে অনুরোধকারী সার্ভারের অনুমোদিত বা ধারনাক্ষমতার বেশি পরিমানে রিকোয়েস্ট করেছেন।
304196358_0afd41ba2e

414 Request-URI Too Long</span>

এ কোড দ্বারা বুঝায় যে প্রদত্ত URI সার্ভারের প্রসেস করার জন্য যথেষ্ট বড়।

415 Unsupported Media Type

এ কোডটি বুঝায় সার্ভার বা রিসোর্চ সাপোর্ট করে এমন কোন মিডিয়া ফাইল রিকোয়েস্ট করা হয় নি।

416 Requested Range Not Satisfiable

এ কোডটি বুঝায় যে ক্লায়েন্ট একটি ফাইলের শুধু একটি অংশের জন্য অনুরোধ করেছেন কিন্তু সার্ভার সেই উল্লেখ্য অংশটি সাপ্লাই করতে পারছে না।

417 Expectation Failed

এ কোড দ্বারা বুঝায় Expect request-header field এর জন্য প্রযোজ্য যোগ্যতা সার্ভারটির ক্ষমতার সাথে মিলছে না।

418 I'm a teapot

এ কোডটি দ্বারা বুঝায় HTCPCP সার্ভার একটি teapot। RFC 2324, Hyper Text Coffee Pot Control Protocol অনুসারে এ কোডটিকে একটি প্রথাগত IETF April Fools' jokes হিসেবে ব্যাখ্যা করা হয়েছে।

422 Unprocessable Entity (WebDAV) (RFC 4918)

এ কোডটি বুঝায় রিকোয়েস্টটির কাঠামো সঠিক ছিল কিন্তু অর্থগত কারনে এটা অনুসরন করা সম্ভব নয়।

423 Locked (WebDAV) (RFC 4918)

এ কোডটি বুঝায় যে রিসোর্স অনুরোধ করা হয়েছিল তা লক করা অবস্থায় আছে।

424 Failed Dependency (WebDAV) (RFC 4918)

এ কোডটি বুঝায় পূর্ববর্তি রিকোয়েস্টটি ব্যর্থ হওয়ার করনে উক্ত রিকোয়েস্টটিও ব্যর্থ হয়েছে।

425 Unordered Collection (RFC 3648)

এ কোডটি "WebDAV Advanced Collections Protocol" এ পাওয়া যায়ে কিন্তু "Web Distributed Authoring and Versioning (WebDAV) Ordered Collections Protocol" এ অনুপস্থিত।

426 Upgrade Required (RFC 2817)

এ কোডটি বুঝায় ক্লায়েন্টকে অন্য প্রোটোকল যেমন TLS/1.0 এ সুইচ করতে হবে।

449 Retry With

এটি একটি মাইক্রোসফটএর এক্সটেনশন নির্দেশ করে এবং বুঝায় যে সঠিক কার্য সম্পাদনের পর পুনরায় রিকোয়েস্ট করতে হবে।

450 Blocked by Windows Parental Controls

এটিও একটি মাইক্রোসফট এক্সটেনশন নির্দেশ করে। যখন উইন্ডোজ পেরেন্টাল কন্ট্রোল অন করা থাকে তখন এ কোডটি প্রদর্শিত হয় এবং রিকোয়েস্ট করা ওয়েবপেইজটির অ্যাকসেস বন্ধ করে দেয়া হয়।

5xx Server Error

এ শ্রেনীর কোডগুলো তখনই প্রদর্শিত হয় যখন সার্ভার দৃশ্যত একটি ভ্যালিড রিকোয়েস্ট পূরণ করতে ব্যর্থ হয়।
রিস্পন্স স্টেটাস কোডের শুরুতে “5” থাকার মানেই হলো সার্ভারে কোন ত্রুটি দেখা দিয়েছে বা এটা কোন রিকোয়েস্ট সম্পাদিত করতে সক্ষম নয়। শুধু HEAD ফাইল ছাড়া, অন্যক্ষেত্রে সার্ভার রিস্পন্স এর সাথে ভুলের ব্যাখ্যা সহ একটি এনটিটি যুক্ত করে দিবে এবং এ ভুলের স্থায়ী সম্পর্কে ধারনা দিবে। ব্যবহারকারীর এজেন্ট উল্লেখিত এনটিটি ব্যবহারকারীকে প্রদর্শন করবে।
নিচের রিস্পন্স কোডগুলো যেকোন রিকোয়স্ট পদ্ধতির জন্য্ই প্রযোজ্য:

500 Internal Server Error

এ কোডটি বুঝায় যখন সার্ভার সৃষ্ট সমস্যার কোন কারন খুজে না পায় তখন এ স্টেটাস কোডটি প্রদর্শন করে।
internalservererror

501 Not Implemented

এ কোডটি দ্বারা বুঝায় সার্ভার রিকোয়েস্ট পদ্ধতিটি বুঝতে পারছে না অথবা এটি রিকোয়েস্ট পূর্ণ করতে সক্ষম নয়।

502 Bad Gateway

এ কোডটি থেকে বুঝা যায় সার্ভারটি একটি gateway বা proxy হিসেবে কাজ করছিল এবং ডাউন-স্ট্রীম সার্ভার থেকে একটি ইন-ভ্যালিড রিস্পন্স প্রাপ্ত হয়েছে।
502

503 Service Unavailable

এ কোডটি বুঝায় সার্ভারটি বর্তমানে বন্ধ আছে। সাধারনত, এ কোডটি অস্থায়ী অবস্থা বুঝাতে ব্যবহৃত হয়।

504 Gateway Timeout

এ কোডটি থেকে বুঝা যায় এ কোডটি থেকে বুঝা যায়: সার্ভারটি একটি gateway বা proxy হিসেবে কাজ করছিল এবং এটি ডাউন-স্ট্রীম সার্ভার থেকে সময় মতো একটি রিকোয়েস্ট পেতে ব্যর্থ হয়েছে।

505 HTTP Version Not Supported

এ কোডটি বুঝায় রিকোয়েস্টে ব্যবহৃত HTTP প্রোটোকলের ভার্সানটি ঐ সার্ভার সাপোর্ট করে না।

506 Variant Also Negotiates (RFC 2295)

এ কোডটি বুঝায় যে অনুরোধটির জন্য স্বচ্ছ কন্টেন্ট-নেগোসিয়েশনের ফলস্বরূপ একটি চক্রকার রেফারেন্স সৃষ্টি হয়েছে।

507 Insufficient Storage (WebDAV) (RFC 4918)

এই অনুরোধটি সম্পূর্ণ করার জন্য পর্যাপ্ত স্থান নেই।
p1

509 Bandwidth Limit Exceeded (Apache bw/limited extension)

এ স্টেটাস কোডটি বোঝায় অনুরোধটি সম্পন্ন করার জন্য যে পরিমান ব্যান্ডউইডথ দরকার সার্ভারের, তা RFCs এ নেই।

510 Not Extended (RFC 2774)</span>

এ কোডটি বুঝায় এ রিকোয়েস্টটি পূর্ণ করতে সার্ভারের জন্য আরো বর্ধিত এক্সটেনশন প্রয়োজন।

সব চাইতে ভালো Internet লাইন পাবেন কোন DNS এ Check করে নিন

আপনের নেট লাইনের জন্য কোন DNS সবচেয়ে ভালো কাজে দিবে তা জানতে পারেন ছোট্ট একটি ওপেন সোর্স সফটওয়্যার Namebench দিয়ে । মাত্র ৫ মেগাবাইটের পোর্টেবল এই সফটওয়্যারটি GoogleDNS , UltraDNS , OpenDNS , সহ আপনার লোকাল DNS চেক করবে ও আপনার জন্য কোনটি সবচেয়ে ভালো তার বিস্তারিত গ্রাফ আকারে দেখাবে । যেহেতু এটি Alexa রেন্কিং প্রথম ১০০০০ ওয়েবসাইট পরীক্ষার ভিত্তিতে ফলাফল দিবে, তাই এটি কিছুটা সময় নেবে ।
সফটওয়্যারটি ডাউনলোড করে রান দিলে ব্লাঙ্ক ফিল্ডে আপনার আইএসপি এর DNS server অ্যাড্রেস দিন ও Start Bench Mark এ ক্লিক করুন কিছুক্ষন পর ব্রাউসারে বিভিন্ন তথ্য সমৃদ্ধ গ্রাফ দেখতে পাবেন । এবার আপনার জন্য যেটি সবচেয়ে ভাল তা সিলেক্ট করে নিন ।

What is IP Address?Let's Try 2 Make Sense

Internet ব্যবহারকারি প্রত্যেকের একটি নিজসব পরিচিতি থাকে যা সাধারনত কতগুলি নিউমেরিক্যল Number দারা প্রকাশ করা হয়, যেমন-192.168.0.1 এই সাংকেতিক নম্বর গুলিই IP address নামে পরিচিত। IP address এর প্রথম চারটি নম্বর হলো খুব গুরুত্তপূর্ন। প্রথম চারটি নম্বর দেখেই বলে দেওয়া যায় নেটওয়ার্ক টি কি ধরনের এবং এর হোস্ট কে। IP address  এই চারটি নম্বর octets নামে পরিচিত, কারন এদের প্রত্যেকের binary form এ আটটি করে স্থান আছে।
এই চারটি নম্বরকে বিভিন্ন শ্রেনীতে ভাগ করে IP address তৈ্রী করা হয়ঃ-
  1. class A: এই ক্লাস এর IP address সাধারনত খুব বড় নেটওয়ার্ক সার্ভিসের ক্ষেত্রে ব্যবহার করা হয়, যেমনঃ বড় বড় আন্তর্জাতিক কোম্পানি। এই সমস্ত IP address এর প্রথম octet টি হয় 1 থেকে 126 এর মধ্যে।
  2. class B: এই ক্লাস এর IP address সাধারনত মিডিয়াম নেটওয়ার্ক সার্ভিসের ক্ষেত্রে ব্যবহার করা হয়। যেমনঃ বড় বড় কলেজ ক্যাম্পাস। এই সমস্ত IP address এর প্রথম octet টি হয় 128 থেকে 191 এর মধ্যে।
  3. class C: এই ক্লাস এর IP address সাধারনত ছোট থেকে মিডিয়াম সাইজের বিজনেস নেটওয়ার্ক সার্ভিসের ক্ষেত্রে ব্যবহার করা হয়।এই সমস্ত IP address এর প্রথম octet টি হয় 192 থেকে 223 এর মধ্যে।
  4. class D: এই ক্লাস এর IP address সাধারনত multicasts (স্পেশাল গ্রুপ আ্যড্রেস) নেটওয়ার্ক সার্ভিসের ক্ষেত্রে ব্যবহার করা হয়।এই সমস্ত IP address এর প্রথম octet টি হয় 224
  5. Class E: 225 দিয়ে শুরু এই IP address ব্যবহার করা হয় সাধারনত গবেষনার ক্ষেত্রে।
  6. Loopback : 127.0.0.1 এই ধরনের IP address ব্যবহার করা হয় loopback এর ক্ষেত্রে। অর্থাৎ troubleshooting এবং নেটত্তয়ার্ক টেস্টিং এর ক্ষেত্রে। আপনার IP address 127.0.0.1 এই আকার ধারন করলে জানবেন, আপনার কার্‌্যকলাপ চেকিং করা হচ্ছে।
  7. Broadcast - Broadcast ম্যসজ সবসময় 255.255.255.255 এই ধরনের IP address ব্যবহার করে।
আপনার আসল IP address এর অবস্থান কি জানতে হলে এই লিঙ্ক এ জানঃ http://www.ip2location.com/
আপনি যদি IP address এর সাহয্যে  আপনার ভিজিটরের অবস্থান জানতে চান, তাহলে লিঙ্ক এ জানঃ

How 2 Change IP Address

একটি মিনিটের মধ্যে আপনার IP Address পরিবর্তন করতে চাইলে নিম্নলিখিত ধাপ গুলো অনুসরণ করুন।
১ প্রথমে আপনাকে Start >Run গিয়ে টাইপ করুন command তারপর ok ক্লিক করুন।নিচের মত একটি MSDOS prompt screen দেখতে পাবেন।
com.JPG
২ এবার টাইপ করুন ipconfig /release তারপর enter চাপুন। exit লিখে prompt থেকে প্রস্থান করুন।
৩ Desktop থেকে My Network Places উপরে রাইট ক্লিক করে properties যান।
৪ তারপর Local Area Connection উপরে রাইট ক্লিক করে properties যান।
৫ এবার Internet Protocol (TCP/IP) পরপর দুই বার ক্লিক করুন।
৬ Use the following IP address ক্লিক করে (আপনার ইচ্ছা মত ) একটি আই.পি.address টাইপ করুন।
lan.JPG
৭ অটোমেটিক ভাবে Subnet Mask পূরণের জন্য Tab চাপ দিন।দুই বার ok ক্লিক করে Local Area Connection ফিরে আসুন।
৮ আবার Local Area Connection উপরে রাইট ক্লিক করে properties যান তারপর Internet Protocol (TCP/IP) পরপর দুই বার ক্লিক করে "Obtain an IP address automatically" select করুন। ok তে ক্লিক করুন। তারপর আবার ok ক্লিক করুন। এবার দেখুন আপনি একটা নতুন IP address পেয়ে গেছেন।
এই ট্রিকটা শুধু আপনার dynamic IP address পাল্টে দেবে কিন্তু ISP/IP address বদলাবে না।তাই এটা দিয়ে আপনি যদি কোন ওয়েব সাইট হ্যাক করেন আর তারা যদি একটু চেষ্টা করে তাহলেই আপনি ধরা পড়বেন।

How 2 Change MAC Address

আজ আমি আপনাদের সেখাব কি ভাবে MAC Address Change করতে হয়.....
আমরা যারা Broadband Internet ব্যবহার করি তারা অন্য কোন কম্পিউটারে Connection টি ব্যবহার করতে পারি না। কারণ, Local ISP সংযোগ প্রদানের সময় LAN Card এর Physical Address বা MAC Address টি নেয় এবং শুধুমাত্র ঐ MAC কেই নেটওয়ার্কে এক্সেস করার অনুমতি দেয়। যার ফলে আমরা অন্য পিসিতে একই কানেকশন ব্যবহার করতে পারি না। কিন্তু MAC Address Change করে সার্ভিস প্রোভাইডারকে বৃদ্ধাঙ্গুলি দেখিয়ে অন্য পিসিতেও একই সংযোগ ব্যবহার করতে পারবেন।
Solution No-1

tmacch.PNG
যে পিসিতে সংযোগটি ব্যবহার করবেন সেটিতে সফটওয়্যারটি ইন্সটল করে নিন। এতে নেটওয়ার্ক কানেকশনটি এবং নেটওয়ার্ক কার্ডের MAC Address দেখতে পাবেন। এখন Change MAC বাটনে ক্লিক করে উপরের খালি বক্সে আপনার NIC এর MAC Address টি টাইপ করে Change Now! বাটনে ক্লিক করলে সাথে সাথে MAC Address টি পরিবর্তন হয়ে যাবে। এবার IP বসিয়ে পিসি Restart করুন এবং উপভোগ করুন। তবে অনুগ্রহ করে অসৎ উদ্দেশ্যে এটি ব্যবহার করবেন না। ডাউনলোড করুন।

Solution No-2
LAN Card Physical Address বা MAC Address ওদের সার্ভারে সেভ করে রাখে।
MAC Address পরিবর্তনের মাধ্যমে এই সমস্যা থকে পরিত্রান পেতে পারি ।
কিভাবে করব এই MAC Address পরিবর্তন ??
যে পিসিতে কানেকশন আছে ঐ পিসির My Network Places এর যান । Local Area connection এর উপর ডাবল ক্লিক করুন । তারপরsupport ->  Details ক্লিক করে Physical Address লিখে রাখুন ।
এরপর নতুন যে পিসি তে কানেকশন দিতে চান ঐ পিসির Local Area connection এর Properties এ যান । তার পরconfigure -> Advance থেকে Network Address ক্লিক করুন ।
Value তে লিখে রাখা Address বসিয়ে ok করুন ।
এখন আপনি ২ পিসিতেই নেট ব্যবহার করতে পারবেন ।

Thursday, June 4, 2015

Provide Bandwidth Anywhere in Bangladesh

আপনি কি Local Internet Service Provide করার জন্য অথবা School, College, University, Office এ Corporate ব্যাবহার করার জন্য Bandwidth খুঁজছেন? তাহলে আজই যোগাযোগ করুন আমাদের সাথে। আমরা দেশের যেকোনো জেলাতেই Bandwidth দিতে পারি। যে কোন ধরনের Bandwidth সংযোগ জন্য আজই নিচের নাম্বারে যোগাযোগ করুন।

Contact Us:
Name- Tanvir Ahmed 
FB Id- Tanvir Ahmed
FB Fan Page Id- TRST Network
Skype Id- tanvir.sta
Twitter Id- statanvir

Friday, April 24, 2015

একই Internet Connection অন্য Computer এ ব্যবহার

কোন রকম সফটওয়্যার ছাড়াই একই ইন্টারনেট সংযোগ অন্য কম্পিউটারে ব্যবহার করা যায়। এ জন্য দুটি কাজ করতে হবে। প্রথমত কম্পিউটারের MAC address খুজে বের করা এবং দ্বিতীয়ত MAC address পরিবর্তন করা।
MAC address সনাক্তকরণঃ কম্পিউটারের run বাটানে cmd লিখে enter দিন। নিচের window আসবে ।
156.jpg

এবার নতুন window তে ipconfig/all লিখে enter দিন।
238.jpg

এ window-র লাল চিহ্নিত অংশ হল MAC address
334.jpg

MAC address পরিবর্তনঃ
Run button এ click করে regedit লিখে enter দিন। এবার HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002BE10318} খুজে বের করুন এবং double click করে expand করলে 4 digit এর কতগুলো subkeys (0000.0001,0002,0004........0009) দেখবেন।
157.jpg

এবার আপনার কম্পিউটারের diverdesc খুজে বের করুন নিম্ন উপায়ঃ
239.jpg
335.jpg
427.jpg

এবার যে subkeyতে আপনার diverdesc রয়েছে সেখানকার orginal network address এ রাইট বাটন ক্লিক করে Modify option গিয়ে যে কম্পিউটারে ইন্টারনেট সংযোগটি দিতে চান তার MAC address লিখে ok দিন ও কম্পিউটার restart করুন।
527.jpg

kilo bit per second VS Kilo Byte Per Second (kbps VS KBps)

kilo bit per second VS Kilo Byte Per Second (kbps VS KBps)

আমি এই পোস্টে kbps এবং KBps বা KB/s এর মদ্ধ্যে বিভ্রান্তি দূর করার চেষ্টা করব । আশা করি আপনি এই পোস্ট পড়ার পর আপনার কাছে এটা পরিষ্কার হবে আর আপনার বিভ্রান্তিটাও দূর হবে। এই বিষয়ে এর পূর্বেও পোস্ট হয়েছে । তবুও বিষয়টাকে নতুন করে উপস্থাপন করলাম। আশা করি সবাই ক্ষমাসুন্দর দৃষ্টিতে দেখবেন।অধিকাংশ ব্রাউজার, ডাউনলোডার এবং FTP সহ অধিকাংশ সফটওয়ার KBps (Kilo Byte Per Second) এর মাধ্যমে ডাটা স্থানান্তরের হার প্রদর্শন করে। কিন্তু ইন্টারনেটের মাধ্যমে ডাটা ট্রান্সফার গতি প্রতি সেকেন্ডে kbps (kilo bit per second) সিস্টেমে গণনা করা হয় ।অর্থাৎ, Internet Bandwidth আসে kbps (kilo bit per second) সিস্টেমে এবং ডাউনলোডের গতি প্রদর্শিত হয় KBps(Kilo Byte Per Second)
  • kbps (kilo bit per second) এবং KBps (Kilo Byte Per Second) এর পার্থক্য বুঝতে না পেরে মানুষ সবচেয়ে বেশি বিভ্রান্তির শিকার হয়।
  • 1kbps (1 kilo bit per second) কে আমরা যদি 1KBps 1kBps KB/s লেখি তাহলে আমরা ভুল করব।
  • 1KBps(1 Kilo Byte Per Second) কে আমরা 1KBps/ 1kBps KB/s লেখতে পারি।
আমরা যখন মোবাইল/ব্রডব্যান্ড/ওয়াইম্যাক্স অপারেটরদের থেকে ডাটা কিনি, তখন তারা প্রতিশ্রুতি দেয় এভাবে যে, আপনার সংযোগ 512kbps (512 kilo bit per second) এবং আপনার লিমিট 5 GB(5 GigaByte) বা লিমিট নেই বা ফেয়ার ইউসেজ পলিসি থাকবে কিনা ইত্যাদি ইত্যাদি।
কিন্তু আপনি সংযোগ নেবার পর স্পিড দেখে বলবেন আই এস পি আপনাদের ঠকায় এবং নিম্ন মানের সেবা প্রদান করে, প্রকৃতপক্ষে তা বলার অবকাশ নেই কারন আপনি তার সাথে আগেই উপরিক্ত চুক্তি বদ্ধ। উপরিক্ত চুক্তি অনুসারে আপনার স্পিড প্রকৃতপক্ষেই পাবার কথা 62.5 KBps( 62.5 Kilo Byte Per Second) আশা করি বুঝেছেন।

এখন নিচের চার্টটা দেখুন তাহলে একটু ভালভাবে বুঝতে পারবেন

Internet connectivityDownload speed (approx)
256 kbps31.3 KBps
384 kbps46.9 KBps
512 kbps62.5 KBps
768 kbps93.8 KBps
1 mbps ~ 1000kbps122.1 KBps

আরো ভালভাবে বুঝবার জন্য নিচের চার্ট দেখব এবং অংক করব। খেয়াল করুন নিচের চার্টটিঃ

Conversion Calculator
bitbit0 or 1
1byteB8 bits
1kibibitKibit1024 bits
1kilobitkbit1000 bits
1kibibyte (binary)KiB1024 bytes
1kilobyte (decimal)kB1000 bytes
1megabitMbit1000 kilobits
1mebibyte (binary)MiB1024 kibibytes
1megabyte (decimal)MB1000 kilobytes
1gigabitGbit1000 megabits
1gibibyte (binary)GiB1024 mebibytes
1gigabyte (decimal)GB1000 megabytes
1terabitTbit1000 gigabits
1tebibyte (binary)TiB1024 gibibytes
1terabyte (decimal)TB1000 gigabytes
1petabitPbit1000 terabits
1pebibyte (binary)PiB1024 tebibytes
1petabyte (decimal)PB1000 terabytes
1exabitEbit1000 petabits
1exbibyte (binary)EiB1024 pebibytes
1exabyte (decimal)EB1000 petabytes
এটি আমরা একটি সুত্রের সাহায্যে করতে পারি,

সুত্রঃ

ডাউনলোড KBPS স্পিড = {(Kbps value*1000) /8)} / 1024

নিচে বিস্তারিত লিখছিঃ

ধরুন আপনি 512kbps এর সংযোগ নিয়েছেন,
তাহলে,আমাদের kbps value=512
যেহেতু, 1kb(kilobit)=1000bit সেহেতু, 512kb=512kb*1000bit=512000bit,
আবার,
যেহেতু, 8bit=1byte, সেহেতু, 512000bit=512000bit/8=64000byte,
আবার,
যেহেতু, 1024byte=1kilobyte সেহেতু, 64000byte=64000byte/1024=62.5 KB
অর্থাৎ, 512kbps লাইনে আমরা স্পীড পাব 62.5 KB/s
বাস্তবিক পক্ষে আমরা কিন্তু একটু বেশিই পাই। ওরা আমাদের মোটেই ঠকাচ্ছে না। হয়তবা, আমরাই একটু কম বুঝি।
সবচাইতে সহজ হবে আপনি আপনার আই এস পির kbps ভেলুর সাথে 0.1220703125 দিয়ে গুন দিন তাহলেই KB/s স্পীড পেয়ে যাবেন।

আর কিছু জানার থাকলে যোগাযোগ করুন- 
Contact us:
Name- Tanvir Ahmed
Facebook Id- Tanvir Ahmed
Facebook Page- TRST Network

Share it

Twitter Delicious Facebook Digg Stumbleupon Favorites More